Connectivity issues from Spain
Incident Report for Redbooth
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 13, 2016 - 08:58 UTC
Identified
Assets and Files uploaded to Redbooth could be not available from Spain due to issues with locals ISP
Posted over 1 year ago. Oct 13, 2016 - 08:14 UTC