Connectivity issues
Incident Report for Redbooth
Resolved
And we're back! Sorry for the trouble!
Posted about 1 year ago. Sep 16, 2016 - 10:06 UTC
Investigating
We are currently experiencing connectivity issues and our engineers are already working on a fix.
Posted about 1 year ago. Sep 16, 2016 - 09:44 UTC