Redbooth Home Page experiencing intermittent loading issues
Incident Report for Redbooth
Resolved
We found the issue that was causing intermittent loading issues with Redbooth's home page and have fixed it. Thank you for your patience.
Posted over 1 year ago. Feb 18, 2016 - 21:27 UTC
Identified
Redbooth.com's home page is currently having intermitting loading issues. We will provide an update once this issue is resolved.
Posted over 1 year ago. Feb 18, 2016 - 21:18 UTC