Redbooth.com Degradation 1/26/2017
Incident Report for Redbooth
Resolved
We have resolved the issue concerning slow response to load Redbooth.com All services are back to normal.
Posted 6 months ago. Jan 26, 2017 - 16:59 UTC
Investigating
We are investigating reports that Redbooth.com is having loading/sluggishness. More information to come as we have it.
Posted 6 months ago. Jan 26, 2017 - 15:41 UTC